Consider the following two files:  app.js  import Game       from './game/game'; import React      from 'react'; import ReactDOM   from 'react-dom';  export default (absPath) => {   let gameElement = document.getElementBy...
I'm trying to create a module that exports multiple ES6 classes. Let's say I have the following directory structure:  my/ ??? module/     ??? Foo.js     ??? Bar.js     ??? index.js   Foo.js and Bar.js each export a default ES6 class:  // Fo...
I'm stuck with the following error when trying to build a react app with Webpack4 and Babel7.   ERROR in ./src/index.js Module build failed (from ./node_modules/babel-loader/lib/index.js): Error: Cannot find module 'babel-preset-react' fr...
I`m tryng to use Babel-loader on an old project, and i notice some issues regarding when babel loader is working on wrapped objects, is this its default behaviour ? I am not sure if this is a bug or something im doing wrong, i could not find much abo...
I have a small /javascript,Babel script, that runs just fine in Chrome and Firefox browsers, but it fails in Internet Explorer 11.  I hope somebody can help me.  Here is my function:  getDaysWithEvents() {     // Get all the days in this months calen...
the babel docs say the modules default option is auto, what does the auto means? does it transform the "import" to "require" or not? what's the difference between "modules: false" and "modules: auto"? it seems they...
I just updated the React Native from 0.55 to 0.56.  However, when I tried to run the code (react-native run-android OR run-ios), bundling stops to this point:  Loading dependency graph, done. error: bundling failed: TypeError: Cannot read property &#...
I'm trying to use javascript ES7 syntax on the server using node.js with webpack and babel-loader (es2015 + stage-0 presets). I've gotten it to work with babel-node but when I run webpack I get the following error at the async keyword (9:22 i...
I have the following gulpfile.js:  var gulp = require('gulp'); var browserify = require('gulp-browserify'); var concat = require('gulp-concat');  gulp.task('browserify', function() {     gulp.src('js/ScheduleMain.j...
I updated react-native to v0.57 and react-native run-ios is failing. I replaced babel-preset-react-native with metro-react-native-babel-preset as suggested in https://www.npmjs.com/package/babel-preset-react-native. here is the error stack trace I am...

Tags

Recent Questions

Top Questions

Home Tags Terms of Service Privacy Policy DMCA Contact Us

©2020 All rights reserved.