yarn install v0.20.3 [1/4] ???? Resolving packages... [2/4] ???? Fetching packages... [3/4] ???? Linking dependencies... warning "[email protected]" has incorrect peer dependency "[email protected]^3.4.2". [4/4] ???? Building fresh packages... ? Done in 77.59s.
I've looked online to find out exactly what "has incorrect peer dependency" means. But all I can find are reported issues on other repositories or questions about how to fix the problem.
Can someone explain what this means and why it is only a warning, and not an error?
Also, is it something that I should try to address or report to the community behind the repo I have just cloned?
It is only a warning as it won't actually stop your code from running, It's just there to give you a heads up that there's something wrong with your dependencies.
Effectively, peer dependencies are a way for packages to specify, "to use me, you should also have x version of y package installed".
You should upgrade to the latest versions, see this link for more details on sass-loader dependencies
I think that there are packages for which it doesn't make a big difference (if not exposed in your app or not likely that conflicting versions create problems, e.g. moment.js), but then there are packages, like React, for which it matters that all React dependencies are compatible with each other as they might create components that have to understand each other.
In your case, probably one of your dependencies uses
sass-loader in a different version than you specify in your project.
By declaring it as a
peerDependency you can tell npm which version your project expects and it will give you a warning (as you saw) when there is a conflict.
©2020 All rights reserved.