[$sce:iequirks] Strict Contextual Escaping does not support Internet Explorer version < 9 in quirks mode

Once I upgrade AngularJS from 1.0.7 to 1.2.0rc1 I get the following error:

[$sce:iequirks] Strict Contextual Escaping does not support Internet Explorer version < 9 in quirks mode
  • I have already added <!doctype html> but to no avail.
  • I also need to support IE7 (sob).

Answers:

Answer

From the github issue related to this problem - $sce does not support IE7 in standards mode.

The minimum bar for $sce is IE8 in standards mode. IE7 standards mode is not supported. If you must support IE7, you should disable $sce completely.

To disable $sce:

angular.module('ie7support', []).config(function($sceProvider) {
  // Completely disable SCE to support IE7.
  $sceProvider.enabled(false);
});
Answer

This has been answered, but somebody might find this useful: in IE(8) turn off Compatibility View - that "broken page" icon after address bar

Tags

Recent Questions

Top Questions

Home Tags Terms of Service Privacy Policy DMCA Contact Us

©2020 All rights reserved.