What are the ES6 features that babel cannot compile to ES5 while building?

I am unable to find a defined set of features that Babel compiler cannot compile. I know that there is babel-polyfill and core.js but I need to know the exact names of es2015 features which babel compiler cannot compile.

Any help would be appreciated.

Thanks

Answers:

Answer

There is an amazing site that gives you all the information you will want on transpiler compatibility, browser and even mobile support.

Have a look at this.

The second column is for Babel. The categories are on the left. If you click the little right arrow symbol you can even see the tests that provide compliance - I think that is an fabulous feature!

The latest release of Babel has improved their numbers. It was just over 50% prior to latest. Now they are at 71% (Feb 21, 2017).

You can even switch to see what ES5 support is still lacking or look into the future with leading edge changes (2016+).


In terms of the core.js polyfills, this link provides an index on the feature support provided. This is broken out in terms of features, and if you navigate to one of them you will be taken to a list of the modules that provide the new capabilities. Each of these modules can be packaged separately, so you can pick and choose what you want if the size of the script is of concern. See this link for more details on using only selected modules.

Tags

Recent Questions

Top Questions

Home Tags Terms of Service Privacy Policy DMCA Contact Us

©2020 All rights reserved.